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1. Overview
 
GSadjust is a cross-platform graphical user interface for least-squares network adjustment
of combined absolute and relative gravity surveys. The software is a product of the USGS
Southwest Gravity Program. The purpose of GSadjust is to facilitate the efficient processing
of field gravity surveys. The program is useful for both synpotic ("snapshot") gravity surveys
or surveys of gravity change over time. The program does not perform gravity inversion or
otherwise interpret gravity data.
 
The objective of network adjustment is to determine a single, best-fit gravity value at each
station based on all available measurements and their respective uncertainty. Typically the
measurements are relative-gravity differences between stations, observed with a relative-
gravity meter, and absolute-gravity measurements at individual stations, observed with an
absolute-gravity meter. The reason relative-gravity differences are used instead of individual
relative-gravity meter observations has to do with the nature of the relative-gravity meter,
which is subject to constant, random drift and occasional tares, or offsets. Usually there will
be more relative-gravity observations than absolute-gravity observations, and there will be
redundant data (that is, more than the minimum data necessary to determine a gravity value
at each station). 
 
Although various software packages exist for least-squares network adjustment of survey
measurements, gravity networks present unique considerations not present in other
methods. First, the primary instrument used in spatially-distributed measurements of the
Earth's gravity field is the relative-gravity meter, the zero-point of which drifts randomly
and unpredictably. Plotting relative-gravity meter drift over time is considered essential
for an accurate accounting of the meter's behavior. Second, it is widely recognized that
gravity measurements are susceptible to various errors and "outlier" measurements are
not uncommon. Network adjustments often proceed iteratively, including or excluding
observations based on the statistical properties of the network. For these reasons the
gravity-specific graphical interface GSadjust was developed for network adjustment.
 
GSadjust builds on the software PyGrav (Hector and Hinderer, 2016). Compared to PyGrav,
GSadjust offers enhanced plotting and analysis of relative-gravity meter drift, additional
methods for drift correction (beyond inclusion as a parameter in the adjustment), and
inclusion of absolute-gravity observations. GSadjust also offers additional functionality for
network adjustment, including plotting results, enabling/disabling gravity differences, and
calculating the change in gravity over time. GSadjust is written in Python 3 and the PyQt5
graphical user interface framework, and is public domain.
 
The software and related documentation on these web pages were developed in part by the
U.S. Geological Survey (USGS) for use by the USGS in fulfilling its mission. The software
can be used, copied, modified, and distributed without any fee or cost. Appropriate credit is
requested. The USGS provides no warranty, expressed or implied, as to the correctness of
the furnished software or the suitability for any purpose. The software has been tested, but
as with any complex software, there could be undetected errors.
 
Any use of trade, firm, or product names is for descriptive purposes only and does not imply
endorsement by the U.S. Government.
 

http://go.usa.gov/xqBnQ
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Installing GSadjust
 

GSadjust is provided as Python source code and an accompanying Python environment.
The download is located at:
 
https://code,usgs.gov/sgp/sgp-gsadjust
 
On Windows, GSadjust is run by unzipping and running GSadjust_launcher.bat.
 
On Mac and Linux platforms, a Python environment must first be created. A requirements.txt
file is provided for use with pip for creating the environment. Alternatively, the Windows .zip
download can be run inside a Windows virtual machine.
 

http://go.usa.gov/xqBnQ
https://code,usgs.gov/sgp/sgp-gsadjust
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Data Organization
 
Data in GSadjust are organized in a hierarchical tree. At the top-most level is the Campaign,
which contains all of the data in a project, typically from a particular field area. The user
does not generally interact with the Campaign object. Each Campaign has one or more
surveys, which represent all of the data combined in a network adjustment. If more than
one survey is present, gravity change over time can be calculated. Each survey has one
or more loops; the drift correction is specified on a per-loop basis. Each loop has two or
more (station) occupations. A station may be occupied one or more times in a Loop. Finally,
each occupation has one or more samples. Typically during a relative-gravity measurement
several samples are taken (often at a 5 second interval for the Burris meter, or 90 second
interval for Scintrex meters).
 
The content of the Drift tab is determined by the currently selected Loop, indicated by
bold type. Similarly, the content of the Network Adjustment tab is determined by the
currently selected Survey, also in bold. The selected Loop or Survey is changed by
double-clicking on the Loop/Survey name.
 

http://go.usa.gov/xqBnQ
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Samples
 
A sample in GSadjust is a single observation (meter reading) at a station occupation.
Usually any particular station occupation consists of several samples taken in relatively
quick succession without moving the relative-gravity meter. For the Burris meter, the
minimum interval between samples is 5 seconds if ambient noise is sufficiently low. For
Scintrex meters, the interval is usually longer, about 60 seconds.
 
All of the samples at a station are displayed in the Data table, and plotted, on the Data tab.
 
 
 

http://go.usa.gov/xqBnQ
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Occupations
 
A (station) occupation includes all of the samples collected during one setup at a station.
If a station is visited multiple times during a survey, each visit is a unique occupation.
Occupations are shown in the left-hand tree view with the station name, average date/time,
and average g. Immediately after the station name, the occupation number is shown in
parenthesis. For example, if the station LC2 were visited 3 times during a loop, the entries
LC2 (1), LC2 (2), and LC2 (3) would appear in the left-hand tree view:
 

 
If samples are excluded by unchecking them in the main data view, the average date/
time and g in the tree view is updated automatically, along with the corresponding gravity
differences on the Drift and Network Adjustment tabs.

http://go.usa.gov/xqBnQ
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Loops
 
A loop in GSadjust refers to all of the data for which a single drift-correction is applied.
Traditionally, loops consist of a series of station occupations that start and finish at the same
station (e.g., A-B-C-D-E-A). In the context of GSadjust, a loop may actually comprise two
loops in the field, e.g. A-B-C-D-E-A-B-C-D-E-A (this double-loop approach is often used in
high-precision surveys). Or, stations in a GSadjust loop need not be visited in any particular
order; the survey A-B-C-B-A-C-D-E-C-A could also be a defined as a single loop. Although
often the same drift-correction method will be used throughout a campaign, the method
could also vary by loop.
 
The following drift-correction methods are available:
None
Network adjustment
Roman
Continuous model

http://go.usa.gov/xqBnQ
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Surveys
 
A survey in GSadjust includes all of the loops (and their respective occupations and
samples) that are combined in a single network adjustment. The survey represents a single
snapshot in time, although in practice, data may be collected over a period of days to weeks
if the gravity field is changing slowly.
 
Surveys can be renamed using the F2 key. The survey name must be in the form of a date
(YYYY-MM-DD), but need not be the same date as the data within the survey. Survey
names don't need to be unique in order to carry out network adjustment, but they do if
computing gravity change. The survey date is used when calculating gravity change trends.
 
If results for more than one survey exist, the difference can be calculated using Compute
gravity change. This can be used to calculate change over time, or to compare processing
styles. For example, The same dataset could be imported twice (first, using Load raw..., then
using Append survey to campaign...), and different drift-correction styles assigned to the
respective loop in each survey. Compute gravity change would then show the difference.
 
 

Survey name
 
The name of a survey. Must be in YYYY-MM-DD format. Press F2 to rename.

http://go.usa.gov/xqBnQ
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Campaign
 
A campaign in GSadjust includes all of the data in a project. Only one campaign can be
opened or analyzed at a time. Campaigns consist of one or more surveys. If there are
multiple surveys, gravity change over time can be calculated.
 
Campaign data, including checked/unchecked status, drift-correction method, and network
adjustment options can be saved or loaded using the File > Save workspace... menu
command. Campaign data are saved in *.gsa files.

http://go.usa.gov/xqBnQ
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Data Tree View
 
The Data Tree View, at the left side of the window, shows the overall organization of the
relative-gravity data. This view allows surveys, loops, and occupations to be activated or
deactivated (with check boxes), and for stations to be organized (and re-organized) into
loops.
 
Stations may be deleted, duplicated, or moved to new loops using the context menu, which
opens when right-clicking on a station name. Several consecutive stations can be selected
by holding down the shift key.
 
Stations can be renamed by pressing the F2 key when the station is selected in the tree
view. A dialog is presented with the option to rename all of the stations in the Campaign, or
only the stations in the same Survey or same Loop.
 
Selecting surveys and loops
 
Certain actions and views in GSadjust act on, or show, the currently selected survey or
loop. For example, when on the Drift tab, only the currently selected loop is shown, and the
selected drift correction method applies only to that loop. On the Adjust tab, only the delta-
g's and datum observations for the currently selected survey are shown, and the network
adjustment is carried out on those observations.
 
A survey or loop is selected by double-clicking the respective name in the data tree view.
The selected survey or loop is shown in bold. In addition, the selected loop has a shaded
gray background.
 

http://go.usa.gov/xqBnQ
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Tree view context menu
 

The Data Tree View has a right-click context menu from which stations can be deleted,
duplicated, or moved to a new loop. Multiple stations can be selected by holding down the
shift key (these operations won't work when non-adjacent stations are selected, as can be
done by holding the control key).
 

Delete survey

Deletes the current survey (the highlighted survey; not necessarily the selected
survey shown in bold).

Delete loop

Deletes the current loop (the highlighted loop; not necessarily the selected survey
shown in bold).

Loop properties

A text note can be added to each loop. This note is saved alongside the station data
when the workspace is saved.

Rename station

A station can be renamed by right-clicking it and selecting Rename station. Or,
press the F2 key. A dialog is shown that gives the option to rename just the selected
station occupation; all instances in the current loop; all instances in the current
survey; or all instances throughout the campaign.

http://go.usa.gov/xqBnQ
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Delete station(s)

Deletes one or more selected stations (stations must be adjacent in the tree view).
To restore deleted stations, data must be reloaded from a text file.
 

Duplicate station

Duplicates the selected station. This feature is useful when creating loops.

Move station(s) to new loop

Creates a new loop with the selected stations.

http://go.usa.gov/xqBnQ
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Tree view toolbar
 

 
The tree view toolbar modifies the survey order, expands and collapses the view, and
provides shortcuts for survey adjustment.

Move survey up

This button moves the currently selected survey upward (before the pervious survey
in the tree view).

Move survey down

This button moves the currently selected survey downward (after the next survey in
the tree view).

Collapse all

This button collapses all surveys and loops.

Expand all

This button expands all surveys and loops.

Adjust current survey

http://go.usa.gov/xqBnQ
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This button adjusts the currently selected survey (also available on the Adjustment
menu).

Adjust all surveys

This button adjusts all surveys (also available on the Adjustment menu).

Scale std. dev. from results

This button scales the standard deviation of the gravity differences (SD for adj. on
the Network Adjustment tab) so that the standard deviation a posteriori approaches
1. Only the gravity-difference standard deviations are scaled; the datum observation
standard deviations are not.

http://go.usa.gov/xqBnQ
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Survey and Loop metadata
 
Information about each Survey and Loop can be displayed by hovering the mouse over the
Survey or Loop name in the Tree view. For example,
 

 
By right-clicking the loop name and selecting Loop properties, the operator, meter, and
comment metadata can be edited:
 

 
Comments are saved with the workspace.

http://go.usa.gov/xqBnQ
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Workflow
 
The GSadjust workflow generally proceeds in three steps:
 

1.  Import and organize data (Data tab)
2.  Correct realtive-gravity meter data for instrument drift (Drift tab)
3.  Network adjustment (Network Adjustment tab)

 
In step 1, data are loaded from the text file output by the relative-gravity meter (Scintrex
or Burris). For each station occupation, individual readings can be deselected as needed,
using the time-series plot of gravity readings as a guide. For larger surveys, stations may
be grouped into loops as needed ("loop" refers to the set of station occupations for which a
common drift correction is applied).
 
In step 2, loops are corrected for drift. Drift-correction options are:

•  None
•  Include in network adjustment
•  Roman menthod (interpolate)
•  Continuous model

Each loop can be assigned a unique drift method.
 
In step 3, the drift-corrected gravity differences are adjusted using the least squares method.
Datum observations ("fixed" stations, i.e., those with a known gravity value) are assigned
and/or loaded from a text file. Adjustment statistics are evaluated and, if needed, gravity
differences can be excluded as outliers.
 
For all but the simplest surveys, it is usually worthwhile to complete all 3 steps before
deselecting individual samples in the Data Table, or before spending much time on the drift
correction. The reason is that errors in station name, tide correction, loop organization, etc.
are not uncommon. It is more efficient to reveal these errors, by carrying out the network
adjustment, before fine-tuning the individual occupations. For example, in the instance of
station name errors, the imported data text file should be updated, and the file re-imported.
 

http://go.usa.gov/xqBnQ
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2. Quick-start tutorial
 

GSadjust is distributed with sample data sets for training purposes. Two fully-processed
examples are available:
 
1.  Simple example: this synthetic dataset includes 5 stations, 11 relative-gravity
observations, and no absolute-gravity observations.
 
2.  Complete example: this real-world dataset includes 38 stations,  271 relative-gravity
observations, and 8 absolute-gravity observations.

http://go.usa.gov/xqBnQ
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Simple example
 
This synthetic dataset consists of a single survey with a single loop consisting of 5 stations,
11 relative-gravity observations, and no absolute-gravity observations. In GSadjust
terminology, in which "loop" refers to all of the observations for which a single drift correction
is applied, the loop consists of two visits to each station, with the first station visited 3 times.
The station order is 1-2-3-4-5-1-2-3-4-5-1.
 
1.  Import data
 

Select "Load raw Burris data..." from the File menu. Open Test1.txt in the test_data/
synthetic directory. Loop 0 is created.
 
In this synthetic example, there is only a single "observation" at each station.
Therefore, the plots on the data tab show only a single point instead of a time series.
Each station name can be selected in the tree view to show the associated data on
the Data tab.
 
Note that the "Update adjustment" status indicator in the bottom right is highlighted,
indicating the adjustment have not yet been performed:

 
2.  Apply drift correction
 

Switch to the Drift tab by clicking "Drift". GSadjust displays a time series of the drift,
with one line per station, starting at 0 for each station (see Drift tab for details).

 
In this example, drift is initially negative, as indicated by downward-sloping lines, but
gradually becomes positive, as indicated by upward-sloping lines.
 
Four options are available for drift correction. The "None" and "Network adjustment"
options do not change the plot. Selecting the "Roman" option updates the plot
with vertical dashed lines to show the delta-g's, and a new table is shown in the
bottom right with the average delta-g's. The "Continuous model" option displays an
additional plot that shows the drift rate over time.
 
For now, proceed with the "Continuous model" option. Select "1st order polynomial"
for the drift model type and "Constant" for the behavior at start/end.

 
3.  Populate delta table
 

Switch to the Network Adjustment tab. From the Adjustment menu, select "Populate
delta table - all surveys" (because there is only one survey and one loop, the other
Populate... options will have the same effect). The delta-g's from the Drift tab are
copied to the table on the Network Adjustment tab.

 
4.  Add datum observation

http://go.usa.gov/xqBnQ
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For this simple example, there are no absolute-gravity observations. Instead, an
arbitrary datum is applied to one of the stations.
 
From the Adjustment menu, select "Add datum observation..." A dialog appears with
a drop-down list of stations:

Select "OK" to select the default, sta1 (any other station is also acceptable, but will
produce different results).
 
An arbitrary gravity value and standard deviation, 50,000 +/- 5 µGal, is applied to
sta1 and shown in the datum observations table. This value can be changed by
double-clicking it in the datum observations table, as can the standard deviation,
measurement height, and gradient. The datum date is an arbitrary string and has no
effect on the results.

 
5.  Perform adjustment
 

From the adjustment menu, select "Adjust current survey" (because there is only one
survey, "Adjust all surveys" will have the same effect). Alternatively, click the button
on the tree view toolbar, or use the keyboard shortcut Ctrl+2. The adjustment will
proceed using the default Numpy method.
 
Adjustment results (a single, best-fit gravity value at each station) are shown in the
adjusted station values table at the upper right. Adjustment statistics are shown in
the table at the lower right. Note that the Chi-test was accepted, and the a posteriori
standard deviation is near one. These indicate the adjustment was acceptable. The
a posteriori standard deviation less than one indicates that the estimated standard
deviation of the observations was higher than the adjustment results indicate. The
delta-g standard deviations can be automatically scaled using the "Scale std. dev.
from results" menu command or the corresponding button on the Tree view toolbar.
After doing so the "SD for adj." value shown on the delta-g table is lowered to 2.7
µGal, and the standard deviation a posteriori is 1.0
 
Note that the "Update adjustment" status indicator in the bottom right is no longer
highlighted.
 
For this simple example, the tools for evaluating results are limited. A histogram of
delta-g residuals ("Plot residual histogram", or Ctrl-H) is uninformative owing to the
small number of observations. Because there is only one datum observation, the
adjusted value matches the observed value exactly and the "Plot adjusted datum vs.
measured" plots only a single value of zero.
 

http://go.usa.gov/xqBnQ


 

GSadjust Manual
USGS Southwest Gravity Program

25

                             

6.  Export results
 

From the Tools menu, select "Write tabular data". A comma-separated value (.csv)
file with the filename "GSadjust_TabularData_..." followed by the date is written
to disk with the values shown in the adjusted station values table. Optionally, the
results table can be highlighted by clicking in the upper-leftmost cell, then right-
clicking and selecting Copy to clipboard. Data can be pasted into Excel or a text file.
 
From the Tools menu, select "Write metadata text". A text file (.txt) with the filename
"GSadjust_MetadataText_..." is written to disk with a narrative summary of the
adjustment. This text can be used in a metadata file.
 
From the Tools menu, select "Write adjustment summary". A text file (.txt) with
the filename "GSadjust_Summary_..." is written to disk showing the observations
used in the adjustment and the results of the adjustment. This file includes all of the
information necessary to re-create the adjustment results.

 
7.  Save the workspace
 

To facilitate future re-processing or evaluation, the workspace should be saved by
selecting "Save workspace as..." from the File menu. A file save dialog is shown;
save with an appropriate filename. A ".gsa" extension is added if not specified. The
workspace is written to file in JSON format. This file can be re-loaded into GSadjust
using the "Open workspace..." command on the File menu. It should not be edited
outside of GSadjust.
 
 

 
 
 

 
 

 
 
 

http://go.usa.gov/xqBnQ
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Complete example
 

This real-world dataset includes 38 stations and 8 absolute-gravity measurements. Two
surveys were carried out, each with two relative-gravity meters.
 
Two saved workspaces are provided. The file gsadjust\test_data\field\Burris
\complete_workspace1.gsa is worked through step 4 below (Earth tide correction). The file
gsadjust\test_data\field\Burris\complete_workspace2.gsa is worked through step 7 below.
These files can be loaded to skip ahead in the tutorial.
 
1. Import relative-gravity data
 

First, load data from the first meter (serial number B44) used on the first survey.
Select "Load raw Burris data..." from the File menu. Open B44_2017-12-05.txt in
the test_data/field/Burris directory. Survey 2017-12-05 and Loop 0 are created and
selected.
 
In this real-world example, each station occupation consists of several samples.
The gravity time series (and feedback, tilt correction, and Earth tide correction time
series) are shown in the table and plots on the Data tab. The respective data for
each station can be shown by selecting the station in the left-side tree view.
 
Next, load data from the second meter (B108) used on the first survey. Select
"Append loop to current survey..." from the File menu. Open B108_2017-12-05.txt
in the test_data/field/Burris directory. A dialog appears to select the meter type;
choose "Burris". Loop 1 is created but not selected. Double-clicking "1" will update
the contents of the Drift tab.
 

 
Load the data from the second survey in a similar manner. First, add the data from
meter B44 (B44_2018-02-27.txt) using "Append survey to campaign...".  A dialog
appears to select the meter type; choose "Burris". Survey 2018-02-27 and Loop 0
are created but not selected (you may need to click the "expand" arrow next to the
survey name to show the loops).  Double-click Survey 2018-02-27 to select it.
Finally, append the data from meter B108 (B108_2018-02-27.txt) using "Append loop
to current survey...". A dialog appears to select the meter type; choose "Burris". Loop
1 is created but not selected.
 

http://go.usa.gov/xqBnQ
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The samples collected at each station occupation are displayed on the table and
plots on the Data tab:

 
For now, don't worry about which samples are included at each station (controlled by
the check boxes in the table). These can be fine-tuned after successful adjustment
results are obtained.
 

2. Edit data
 

Two items need correcting in the raw data before loading: two stations were
collected on the wrong dial setting, and one station must be duplicated so it can be
included in two different loops.
 
The stations collected with the wrong dial setting are obvious from the drift plot. With
the Drift tab displayed, double click 2018-02-27 Loop 1 to select it (data from meter
B108). Note in the drift plot the very large step in the drift:

http://go.usa.gov/xqBnQ
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This is caused by an incorrect dial setting for the first two stations. Its also apparent
by the large difference in gravity for the first two occupations at rg37 and rg26 in the
data tree view:

In this case, these first two station occupations should be deleted. Select them (with
rg37 highlighted, hold down the shift key and click rg26) and right-click to bring up
the context menu. Select Delete station(s). The drift plot is updated.
 
Now, on the updated drift plot, note the single occupation at station rg26 in the
center of the survey, at about 8:00 (click on the orange line to show the station):

This happens in the common situation when the last station of the day is observed
as the first station the following day. Station rg26 was occupied last on 2018-02-27,
and first on 2018-02-28. The point on the plot represents the average time midway
between these occupations. To see this, display the Data tab and select the rg26
occupation at 7:57:

 
First, we'll duplicate rg26 by right-clicking and selecting Duplicate station. Now there
are two identical rg26 occupations in the data tree view:

http://go.usa.gov/xqBnQ
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Select the first one, "rg26 (5)". With the Data tab displayed, select (by shift-clicking)
all of the samples on 2018-02-28:

 
Next, click the "uncheck selected" button at right. The plot and mean gravity value
are updated. In this example, the two occupations have very similar gravity values
but that is not always the case. Repeat with the "rg25 (5.1)" occupation, unchecking
the samples from 2018-02-27. The contents of the tree view are updated to reflect
the checked samples:

 
Now, on the Drift tab, the central point has been replaced by two points on
2017-02-27 and 2018-02-28.

 
3. Organize data
 

Next, each loop needs to be subdivided into smaller loops. Viewing the Drift tab
shows a long gap in the data for each of the surveys (double-click the loop name to
show drift for that loop).
 
For example, Survey 2017-12-05 Loop 0 shows two groups of data separated by an
overnight period without data:

http://go.usa.gov/xqBnQ
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Because these two periods, representing two consecutive days of field work, have
unique drift behavior, they should be divided into separate loops (a loop denotes
the group of stations for which a single drift correction is applied). The loops can
be separated in one of two ways. Generally the easiest is to apply a time-based
threshold, by which gaps in data greater than a specified value are moved to a new
loop. Do this using the "Divide selected loop..." option on the Edit menu. A dialog is
shown where the time threshold can be specified; the default value of 8 hours works
well to divide surveys on successive days.
 
After clicking OK in the threshold dialog, a new loop (Loop 2) is created under the
2017-12-05 survey. Select each loop in the 2017-12-05 survey (by double-clicking
the loop name) with the Drift tab visible to see how the new loops were created
 
An alternate way to divide loops is to select the stations in the tree view (by shift-
clicking or dragging across a group of stations) to be moved to a new loop and
selecting the "Move station(s) to new loop" command on the right--click context
menu.
 
Divide all of the remaining loops using the same time-based threshold. Before
dividing, each loop must be selected by double-clicking the loop name.

 
4. Update tide correction
 

Although the Burris relative-gravity meter (and Scintrex meters) apply a tide
correction, for this study the Agnew model provides a more accurate correction. To
update the tide corrections, from the Edit menu select Tide correction, then choose
the "Agnew" option. A dialog is displayed to enter coordinates:
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The dialog is pre-populated with the mean latitude and mean longitude of the
observations. After selecting OK, the meter-supplied tide correction is removed and
the new tide correction applied. To revert to the meter-supplied tide correction, select
Tide correction from the Edit menu, then "Meter-supplied".
 
Note that the Agnew tide correction is reported to 0.1 µGal, compared to the Burris
internal tide correction which is reported to 1 µGal.

 
5. Apply drift correction
 

Next, click on the Drift tab. The plot title should show Survey 2017-12-05, Loop 0. If
a different survey is shown, double-click "0" under the 2017-12-05 survey to select
Loop 0:
 
The drift plot shows a short period of positive drift (upward-sloping lines) followed by
generally negative drift (downward-sloping lines). This change in drift rate is visible
when when the "Continuous model" drift correction method is selected:

 
For now, select the Roman drift correction method. The plot is updated with vertical
dashed lines to indicate how the gravity differences (delta-g's) are calculated.
The Roman method is a good all-purpose method that accommodates periods of
inconsistent drift.
 
Also apply the Roman drift correction method to the remaining loops by double-
clicking each loop in turn and selecting the Roman method.
 

6. Populate delta table
 

Next, show the Network Adjustment tab, which should be empty. First we want to
copy the gravity differences (delta-g's) from the Drift tab to the Network Adjustment
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tab. When the delta-g's are copied, they retain their link to the data in the tree
view, but not to the delta-g's on the Drift tab. That is, if the gravity value at a station
occupation changes (for example, if samples are unchecked on the Data tab), the
delta-g(s) that include those stations are automatically updated on the Network
Adjustment tab. Any changes on the Drift tab (for example, changing the drift
correction method) are not reflected on the Network Adjustment tab until the delta
table is updated.

 
To populate the delta table for all surveys, select the "Populate delta table - all
surveys" command on the Adjustment menu. Later, when iteratively updating the
observations used in the adjustment (for example, testing a single loop), the other
"Populate delta table" commands are useful.

 
7. Import datum observations
 

The datum observations can be absolute-gravity measurements stored in
*.project.txt files generated by 'g' software used with Micro-g Lacoste absolute-
gravity meters. First, make sure the 2017-12-05 survey is selected (if not, double-
click on it to select). Select "Import abs. g from project files..." from the Adjustment
menu. In the dialog, navigate to the gsadjust\test_data\field\absolute directory. Click
the "Load" button at bottom left. The relevant details from the .project.txt files in the
absolute directory are shown:

Sort by Date (click on the column header), then check the 4 observations from
2017-12-01. Click import and the observations will appear on the datum table.
 
Select the 2018-02-28 survey and import the absolute-gravity observations from
February 2018.
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Shortcut: The saved workspace complete_example2.gsa is saved at this point.
 
8. Perform adjustment
 

Now, sufficient data are present to perform the network adjustment. Network graphs
can be viewed in circular or map-view layout using the two commands on the Tools
menu:
 
Tools menu > Network graph - circular  Tools menu > Network graph - map view

 

 
In the network graphs datum (or absolute-gravity) stations are shown as black
triangles and relative-only stations are shown as red circles.
 
To perform the network adjustment, select "Adjust all surveys" from the Adjustment

menu, or click the corresponding button on the tree-view toolbar: . The Adjusted
station values and Least-squares statistics tables on the Network Adjustment tab will
update. These tables are unique to each Survey; by changing the selected survey
(double-clicking in the tree view) the tables will update.
 
View the adjustment residuals using the "Plot residual histogram command" on the
Adjustment menu (close the network graph window first if it is still open):
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9. Change adjustment options
 

Although the network adjustment was successful and results were obtained, note in
the statistics window (bottom right) that the Chi-test was rejected for both surveys
and the "SD a posteriori" statistic is greater than 1, meaning that the uncertainty
(standard deviation) of the input observations was underestimated (that is, the
observations don't fit together as well as the measurement uncertainty suggests).
Several steps can improve the results:
 
First, note that the standard deviation of many of the delta-g's is very low (sort the
Relative-gravity differences table by clicking on the "Residual" column heading). The
standard deviation will be zero when using the Roman drift correction method if only
one delta-g exists between a particular station pair. Low standard deviations cause
these measurements to be matched nearly exactly (residuals are close to zero),
while measurements with high standard deviation are weighted much less.
 
When surveying with relative-gravity meters, there is a practical lower limit on
how accurately delta-g's can be observed. The delta-g uncertainty includes the
uncertainty from both station occupations, uncertainty from the drift corrections,
and uncertainty from unaccounted tares. A minimum lower limit for delta-g standard
deviation can be specified in the Adjustment options dialog on the Adjustment menu:
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Check the box next to "Minimum standard deviation", keep the default value of 3.0,
and click "Apply to all surveys". Now in the Relative-gravity differences table the 
"SD for adj." column shows the larger of 3 or the uncertainty determined from the
drift adjustment. Note that the input data for the adjustment has changed and the
adjustment results are now outdated, as shown by the status indicator in the bottom
right:

 

Repeat the adjustment ( ) to update results and clear the status indicator.
 

10. Update drift correction
 

After the adjustment the Chi-test was still rejected for the 2017-12-05 survey, but
accepted for the 2018-02-27 survey. While viewing the 2017-12-05 survey on the
network adjustment tab, note that several of the residuals are fairly large: less than
-10 or greater than 10. Sorting the Relative-gravity differences table by Loop shows
that most of the large residuals are associated with Loop 2. Double-click on loop 2 to
select it and display the Drift tab:
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Note the two long segments (red and grey) that stretch across nearly the entire
survey, corresponding to stations rg30 and rg26 (click the line to show the
station name at the top left of the plot). Using the Roman method, relative-gravity
differences are calculated between these two stations and nearly every other station,
with the drift rate interpolated over the 5+ hour period between repeat occupations.
Based on repeat occupations at the other stations, it appears during this 5+ hour
period there was only a short period of high drift (around 17:30 to 18:00), or possibly
a tare, and much lower drift during the remainder of the period.
 
To remove this spurious drift estimate, a maximum time threshold between stations
can be specified by checking the box to the right:

 
Now, any station occupations separated by the specified threshold will be ignored in
the drift calculation (for either the Roman or Continuous drift-correction options).
 
The delta-g's on the Network Adjustment tab are automatically updated.
 

Repeat the adjustment ( ) to update results and clear the status indicator. Now
the Chi-test is accepted for both surveys and the SD a posteriori statistic is close to
1, indicating the standard deviation estimated from the observations is close to the
standard deviation estimated by the network adjustment.
 

12. Fine-tune the individual station values
 

Next, the estimate of the average gravity reading at each station occupation can
be improved by deactivating samples as needed. With the Data tab displayed. go
through each station in the left-hand tree view and deselect samples as needed by
unchecking them in the table on the Data tab. For example, with the Burris meter
often the first 1 or 2 readings appear to be outliers:
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As samples are checked or unchecked, changing the mean gravity value, the
gravity differences on the Drift tab and the Network adjustment tab are updated
automatically. However, the network is not automatically re-adjusted.
 
After improving the estimate of mean gravity at all of the stations, repeat the

adjustment for all surveys ( ). You can also experiment with changing the drift
correction method or adjustment options.
 

13. Update adjustment results
 

Once final station values are determined, appropriate drift corrections made for
each loop, and an initial adjustment performed, the standard deviations should be
scaled so that the standard deviation a posteriori statistic is close to one. This can
be accomplished by the "Scale std. dev. from results" command on the Adjustment

menu, or the  button on the Tree View toolbar. This scales the standard deviation
of each delta-g ("SD for adj." column in the relative-gravity differences table). See
the network adjustment options page for more information about how the scaling is
applied.

 
14. Calculate gravity change over time
 

If more than one survey exists, the change in gravity over time can be calculated
with the Compute gravity change command on the Tools menu. This shows a table
of gravity change over time in the first n-1 columns, and cumulative change in gravity
since the first survey in the next n-1 columns (where n is the number of surveys). If a
station is not present in a survey the null value -999 is shown.
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Three options are available for further analysis. First, a time-series of gravity change
relative to the first observation at each station can be shown by clicking the Plot
button in the gravity change table. Second, if station coordinates are available, a
map view of gravity change can be shown by clicking the Map button. Finally, a more
complete table of results which includes gravity values, uncertainties, coordinates,
and gravity change converted to meters of water using the 1-d horizontal-infinite slab
approximation (41.9 µGal = 1 m of free-standing water) can be shown by clicking the
Show full table button.

 
15. Export results
 

Finally, results can be exported in several ways:
1) The adjusted station values on the network adjustment tab can be
highlighted (clicking the upper left corner highlights all cells), copied by right-
clicking on the table, and pasted into Excel or a text file as tab-delimited
data. Similarly, results can be copied and pasted from the gravity change
table.
2) Adjusted station values can be exported to a comma-delimited text file
using Write tabular data on the Tools menu.
3) A narrative summary of the adjustment, including statistics and the
number of observations, can be written to a text file using Write metadata
text on the Tools command. The resultant text is suitable for describing
the data-processing steps in a metadata file to accompany the adjustment
results.
4) A complete list of all data used in the adjustment can be written to a text
file using Write adjustment summary on the Tools menu.
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Data sets included with GSadjust
 
Several example data sets, both synthetic data and real-world field data, are included with
GSadjust. The synthetic data are generated from known station gravity values with random
noise, drift, and calibration error added. These data are useful for testing whether different
processing methods are capable of recovering the known station gravity values. The field
data were collected using different relative and absolute gravity meters. The "true" station
gravity values are unknown.
 
Synthetic data
 
Five synthetic datasets are provided with GSadjust in the sgp-gsadjust\test_data\synthetic
directory. These test datasets include a range of drift types, number of relative-gravity
meters, calibration errors, and survey designs. The details of each are shown in the
table below. Random error is applied to the synthetic data, which can be used to test
whether GSadjust recovers the known station gravity values through network adjustment.
The parameters defining these datasets (drift rate, calibration error, observation error)
can be modified in the Excel file GSadjust_TestData.xlsx, and the GSadjust input data
regenerated. For example, two test datasets could be generated for an expected level of
relative-gravity meter precision, and evaluated as to whether the adjustment can resolve the
simulated gravity change. Additional test datasets (for example, with tide error) could also be
generated from the examples provided.
 
The synthetic data are simulated as one sample per station. Therefore, when viewed in
GSadjust the plots on the Data tab will only show a single point rather than a time series.
 
Test case one is used in the simple example.
 

Test case Drift
Number of relative-

gravity meters Calibration error Survey type

1 None 1 no Loop

2 Linear 1 no Loop

3 Linear 1 yes Loop

4 Linear 2 yes Loop

5 Nonlinear 1 yes Dense-network
 
Field data
 
Field data are provided from ZLS Corporation Burris relative-gravity meters and from
Scintrex CG-5 and CG-5 relative-gravity meters.
 
Burris data
 
These data were collected using two ZLS Corporation Burris meters. Two surveys were
carried out, one in December 2017 and one in February 2018. The coordinates have
been changed randomly by about 0.15 degree, so if the tide model is updated it will not
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correspond to the exact study area. There is corresponding absolute-gravity data for this
data in the field\Absolute directory. These data are used in the complete example.
 
Scintrex CG-5 data
 
These data were distributed with the original release of PyGrav (Hector and Hinderer, 2016).
 
Absolute data
 
These data were collected using a Micro-g Lacoste, Inc. A-10 absolute-gravity meter.
Data were collected in conjunction with the relative-gravity data in the Burris directory.
Four stations were occupied with the A-10 during each of the relative-gravity surveys. The
gradient was measured at each station and is used to transfer the gravity value from the
A-10 measurement height (about 71 cm) to the land surface.
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3. Data tab
 

The data tab provides functions for viewing samples at each station occupation and tools for
selecting/deselecting samples based on quality criteria.
 

Data Tree View
  The Data Tree View shows the hierarchical structure of the data set, and is common
to all tabs.

 

Data Table
•    The Data Table shows all of the samples for a particular station occupation.
The columns vary depending on the meter type:

Burris Scintrex
Station name Station
Operator Gravity (g)
Meter number Standard deviation
Date/time Tilt x
Gravity (g) Tilt y
Dial setting Temp
Feedback Duration
Tide correction Rejected
Elevation Elapsed time
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Latitude Date/time
Longitude  
 

 

Data Plot Window
The Data Plot window shows graphically the gravity value and accompanying data
for a particular station occupation. For the Burris meter, the plots shown are gravity,
feedback, tilt correction, and Earth tide correction. For the Scintrex meter, the plots
shows are gravity, Tilt X, Tilt Y, and standard deviation.
 
On the gravity plot, if the y-axis range exceeds 20 µGal, the axis is shown in red.
Otherwise the y-axis range is 20 µGal and the axis is shown in black.
 

check selected

Rows in the Data Table can be selected using the mouse; multiple rows can be
selected by holding down the shift or control keys. If unchecked rows are selected,
this button checks them.

check all

Checks all rows in the Data Table.

uncheck selected

Rows in the Data Table can be selected using the mouse; multiple rows can be
selected by holding down the shift or control keys. If checked rows are selected, this
button unchecks them.

uncheck all

Unchecks all rows in the Data Table.

auto uncheck |tilt| >

Unchecks observations with abs(tilt) (X or Y) greater than the specified value. Used
only for Scintrex data.
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auto uncheck SD >

Unchecks observations with standard deviations greater than the specified value.
Used only for Scintrex data.

auto uncheck g >

Unchecks observations with g values that differ from the mean by more than the
specified value.

auto uncheck dur >

Unchecks observations with durations longer than the specified value. Used only for
Scintrex data.

apply all filters

Applies any thresholds for tilt, g, standard deviation, or duration to all samples of the
current station occupation.

apply all filters to all data

Applies any thresholds for tilt, g, standard deviation, or duration to all stations in the
Campaign.
 
WARNING: This can be very slow for large datasets.

Plotting toolbar

This is the standard Matplotlib (plotting utility for Python) tool bar. More info is under
the Plot toolbar heading.

Status bar

 
The status bar at the bottom of the window shows messages about the current
processing status.
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Loading data
 
Burris or Scintrex data can be loaded with the respective "Load raw..." menu commands
on the File menu (see Data Formats for details on each file type.). These open a standard
file open dialog, allowing the user to select a file. The file to be opened is the raw data file
output by the gravity meter software.
 
For both meter types, the corrected gravity reading and the tide correction are read from the
input file. If a different tide correction is applied, the meter tide correction is removed from
the corrected gravity reading and the new correction applied.
 
In a campaign (workspace) with existing data, surveys can also be created by appending a
data file to create a new survey.
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Data Formats
 
GSadjust can import data exported by ZLS (Burris) and Scintrex (CG-3, CG-5, CG-6)
relative-gravity meters. Data from each of these meters is written in a space delimited text
format.
 
When a data file is initially loaded, the appropriate menu option should be selected ("Load
raw CG-3/CG-5 data", "Load CG-6 data", or "Load raw Burris data"). If additional data are
loaded using the "Append survey to campaign" or "Append loop to survey" menu options, a
dialog will be shown allowing the user to specify the data format.
 
ZLS (Burris)
 
Burris data is a space- or comma-delimited output file from the ZPARSE.exe program run on
a Windows computer (if using the Palm field computer), or output from UltraGrav2 software
(if using the Android field computer). The file read by GSadjust is the "single mode data" file.
 
The Burris file may be hand-edited to, for example, remove data from previous surveys.
Care should be taken if the file is edited in Excel, which will typically result in a change in the
date format (from YYYY-MM-DD to MM/DD/YYYY). The date format must be changed back
to the original format if this is the case.
 
Scintrex (CG-3 and CG-5)
 
Scintrex data files are space delimited. The Scintrex file will typically have a header with
information such as the meter operator and the serial number.
 
Scintrex (CG-6)
 
Scintrex CG-6 data can be logged internally in a format similar to CG-3/CG-5 data, or logged
to a handheld field computer in Tsoft format. There is a specific menu import command for
each format.
 
CSV
 
In addition to the meter-specific formats described above, generic data can be imported from
a comma-delimited file. The columns must be in the following order:
 
STATION, LAT, LON, ALT, GRAV, SD, TILTX, TILTY, TEMP, TIDE, DUR, REJ, TIME,
DEC.TIME, TERRAIN, DATE
 
Absolute gravity data
 
Absolute gravity data can be imported from text files or directly from the *.project.txt files
written by the 'g' processing software used by Micro-g Lacoste, Inc. gravity meters.
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Creating loops
 

Loops in GSadjust (the group of stations for which a single drift correction is applied) are
created after a file is loaded. Alternatively, in a campaign (workspace) with existing data
loops can be appended from individual data files using the "Append loop to current survey..."
command on the File menu.
 
Loops can be created based on a time-based threshold or by selecting the stations to move
to a new loop. To use a time-based threshold, use the "Divide selected loop..." command on
the Edit menu. A dialog appears where one can specify the time threshold:
 

 
If there is a gap between stations longer than the elapsed time specified, the data before the
gap will retain the original loop name and data after the gap will be put in a new loop. If there
are multiple gaps longer than the threshold (for example, if data were collected over several
days with gaps each night) multiple loops will be created.
 
To create a new loop within the current Survey from selected stations, select the first station,
hold down shift, then select the last station. Then, right click to show the Data Tree View
Popup menu, and select Move stations to new loop. A new loop is created.
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Duplicate stations
 
If the same station is occupied as the last station on one day, and the first station the
following day, all of the samples are grouped into a single station occupation. This results in
a station with an assigned time midway between the two individual setups, and an averaged
g value. To more accurately represent the survey, the occupation should be duplicated (by
selecting it and using the right-click context menu). Then, the original occupation (observed
first) should have all of the samples collected on the second day unchecked in the Data
Table, and the duplicate station should have all of the samples collected on the first day
unchecked. This should be done prior to using the "Divide selected loop into subloops..."
command.
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Appending data
 
After a data have been loaded, either by importing data or loading a previously saved
workspace, additional data can be appended. This is useful for ongoing projects where
intermediate analysis takes place before data collection is complete; as additional data are
collected they can be appended as a new loop or survey.
 
There are three append options on the File menu: either a new loop can be appended to
the currently selected survey, a new survey can be appended to the campaign, or an entire
workspace saved from a previous GSadjust session can be appended. The first option is
useful primarily for adding a new day's data for a survey currently in progress. The second
option is useful primarily for appending data after a repeat gravity survey has been carried
out. After appending a new survey to a campaign, data can be separated into loops as
needed.
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Selecting data
 
Data are selected or deselected using checkboxes. In the Data tree view, surveys, loops,
or stations may be selected or deselected. In the station table, individual samples may
be selected or deselected. By default, all of the samples, stations, loops, and surveys are
selected after importing.
 
Individual samples at a station occupation may also be selected/deselected using the criteria
described on the Data tab page.
 
Data plots
In the station data view, the currently selected samples are shown with blue markers.
Deselected samples are shown with black markers. The mean value of the selected data is
shown as a horizontal solid blue line.
 
On the Gravity plot only, the y-axis color is changed to red if the range is larger than µGal.
Otherwise, the range is 20 µGal and the axis is shown in black.
 
 

 
 

Deselected data
 
Data are deselected by unchecking the text box in the Station table. Deselected
data are shown in black.

Selected data
 

Data are selected by default. Selected (checked) data are shown in blue.
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Mean value
 
The mean (average) of the selected data is shown as a horizontal solid blue line.
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Plot toolbar
 

This is the standard Matplotlib (plotting utility for Python) tool bar.
 

Home button

Reset original view

Back button

Back to  previous view

Forward button

Forward to next view

Pan check

Pan axes with left mouse, zoom with right

Zoom check
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Zoom to rectangle

Subplots button

Configure subplots

Customize button

Edit curves line and axes parameters

Save button

Save the figure
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4. Drift tab
 

 
The drift tab provides functions for plotting drift and applying drift corrections. Four options
exist:

•  No drift correction
•  Network-adjustment drift correction
•  Roman method
•  Continuous method
 

The drift correction method is selected in a dropdown box on the right sight of the drift
window. The plots and tables shown on the drift tab can vary depending on the drift
correction method. For the no correction, network-adjustment , and Roman method  options,
a plot of gravity change vs. time at each station is shown. For the continuous method option,
an additional plot of drift observations vs. time is shown. For the no correction, network-
adjustment, and continuous method options, a single table of gravity differences (Delta-
g's) is shown, along with relevant details. Delta-g's are only calculated between successive
stations. For the Roman method option, two tables are shown: one with all possible Delta
g's, and another with average Delta-g's (where more than one Delta-g exists between two
stations).
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Plotting options
 

Several options exist on the right-hand side of the drift tab for controlling the drift method
used and the appearance of the drift plots. Some of the options (drift model type, behavior at
start/end, show time-extent of drift observation, and spline tension) are only available when
the Continuous method correction is used.
 
Clicking on a line in the main plot window will show the station name at the top left of the
plot.

 

Drift correction method

Drop down box to specify drift correction method: none, network adjustment,
Roman, or continuous. This option is set per survey and can affect the calculated
delta-g values.

Drift model type

Continuous drift model only: Specify either a polynomial or spline model of
continuous drift. This option is set per survey and can affect the calculated delta-g
values.

Behavior at start/end

Continuous drift model only: The model only extends to the first and last drift
observation, which is a smaller time-span than the first and last station occupation
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(the drift observation is plotted at the midpoint in time between the two occupations
that comprise the drift observation). The drift model can be extrapolated, or
extended at a constant value. If extrapolated, a straigt line is extended with
the same slope as the drift model; in some cases this can lead to extreme drift
corrections for the first and/or last occupations, and a constant value is preferable.
 
This option is set per survey and can affect the calculated delta-g values.
 
Extrapolate:

 
Constant:

Max. time between repeats

For some surveys, a large amount of time may elapse between repeated station
occupations, and these may not be reliable measurements of drift. This option
allows drift observations to be excluded based on the time between station repeats.
Note: the minimum counter value is 00:10. If the counter is above this, but will not
decrease when the down arrow is clicked, it may be necessary to place the cursor
(by clicking the mouse) on either the hour or minutes field.
 
This option is set per survey and can affect the calculated delta-g values.

Show time-extent of drift observation

Continuous drift model only: When checked, the lower plot of drift rate vs. time
includes horizontal lines that extend to the time of the two station occupations that
comprise the drift observation. This option can be useful in determining whether drift
observations are useful for determining the drift model (repeated stations with long
elapsed times can be unreliable for estimating drift). This option only affects plotting,
not the delta-g values.

Weight drift observations.
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Gravity and time observations are weighted in the drift calculation. Only
implemented for constant drift rate.
 
If drift rate is insignificant (according to p=0.05 t-test), the drift equation shown when
hovering the mouse over the line in the plot will be shown in in red:
 

 
 
 
 

Vertical line offset

This slider controls the (arbitrary) vertical offset between lines in the station drift plot.
Varying the slider may be useful to visualize the data, and helps the user
understand the arbitrary nature of the vertical position of each line. This option only
affects plotting, not the delta-g values.

Spline tension

Continuous drift model only: When using a spline as the drift model, this slider
controls the spline tension. Greater values, to the right, result in a smoother spline
and possibly a poorer match to the drift observations. Smaller values, to the left,
result in a wavier spline and drift observations are more likely to be matched exactly.
 
This option is set per-survey and can affect the calculated delta-g values.
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Tares and the tare table
 

Tares, or offsets, occur when the relative-gravity meter reading "jumps" during a survey; a
tare affects all subsequent observations, but does not affect observations recorded prior to
the tare. Tares may be added using the "Process > Add tare..." menu item, which brings up
the dialog:
 

 
Here, the user may specify a date and magnitude of a tare. The tare value is simply
subtracted (or added, if negative) to all relative-gravity observations within the currently-
active loop that are recorded after the specified time.
 
The tare table, shown on the Drift tab, shows tares that have been added. More than one
tare can be applied simultaneously, and tares are cumulative. That is, if a 10 µGal tare
occurs one hour into a survey, and a 20 µGal tare two hours into a survey, after two hours a
30 µGal tare will be subtracted from all subsequent observations.
 
Tares shown in the tare table can be temporarily disabled by unchecking the respective
check box. The delta-g observations shown on the Drift tab are updated immediately.
 
Tares may also be permanently removed by right-clicking on the tare in the Tare table and
selecting "Delete tare."
 
 

 
The time at which a tare occurred is shown by a sold vertical line in the drift window:
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Note that the tare only affects delta-g's that span the time of the tare. Repeat observations
that both take place before the tare, or both after the tare, are unaffected.
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Drift correction
Drift correction is a fundamental processing step for relative-gravity meter surveys. Even
when a drift-correction is applied internally in the meter data-collection computer, there may
be a residual nonlinear drift component that requires further correction. Four options for drift
correction exist in GSadjust:
 
No drift correction
Network-adjustment drift correction
Roman method drift correction
Continuous-model correction
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No drift correction
 
The "None" drift correction method calculates delta-g's between measured values at
successive stations, without further correction. Although not generally used, the method
may be useful for evaluating the magnitude of the drift correction, relative to the uncorrected
delta-g's. The default standard deviation when using the "None" method is 3.0 µGal (the
standard deviation used in the adjustment can be modified in the Network adjustment
options dialog or edited in the delta table).
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Network-adjustment drift correction
 

Network-adjustment drift correction includes polynomial coefficients of a time-dependent
function for drift in the network adjustment solution. With this method, a linear model (1st,
2nd, or 3rd order) is fit to the data:
 

 
where D(t) is the cumulative drift at time t, (t-t0) is elapsed time, dp are the model
coefficients, and a is the degree of the polynomial. The coefficients dp are parameters in the
network adjustment, determined as part of the least-square solution.
 
Linear drift models can be used with either the network-adjustment drift correction option,
or the continuous model option. When a linear model is suitable, the network-adjustment
drift correction may be preferable, because uncertainty in the drift-model parameters is
propagated into the uncertainty estimate of the final station values. One advantage of the
continuous model, however, is the possibility to extend the drift model as a constant value,
as opposed to extrapolating the linear model, at the beginning and end of the loop (see
"Behavior at start/end" under Plotting options). The suitability of a linear drift model can be
evaluated using the continuous model option, after which the drift method can be changed to
the network-adjustment option before adjusting the network.
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Roman method drift correction
 

The Roman (1942) method interpolates a gravity value when there is more than one gravity
observation at a station. A total of three station occupations-two at one station, and one at
an additional station-are used to calculate a delta-g sample [Item (2) below)]. An interpolated
value is calculated for the station with two occupations, and differenced with the measured
value at the other station, to calculate delta-g.
 
In the window below, delta-g's are shown as vertical dashed line. Each measurement is
shown relative to the first measurement at that station (in other words, if the measured
values were plotted, the solid lines would have a vertical separation equal to the gravity
difference between the stations). For the survey shown, which consists of two complete
loops at three stations, there are a total of 12 delta-g's, shown on the Delta-g sample table
(4).
 
As part of the Roman method drift correction, the redundant delta-g's (12 obserations are
possible, but only 3 are required to identify a gravity value at each station) are averaged.
The averaging process is a simple form of network adjustment, with equal weight given to
all observations. For surveys and/or campaigns with only a single loop (including vertical
gradients), the values in the Delta-g average table (5) can serve as final results.
 

Plot window
The main plot window shows the relative-gravity observations at each station,
relative to the first occupation at that station.
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Delta-g sample
Each vertical dashed line represents a delta-g calculated using the Roman method.
There is a corresponding entry in the Delta-g sample table for each dashed line.
 

Plot options
See Plotting options
 

Delta-g sample table
This table displays all of the possible delta-g's calculated using the Roman method.
 

Delta-g average table
This table displays the average delta-g between any two stations in the Delta-g
sample table. If there is only one delta-g between two stations, it will also be
included in the average table.
 

Roman, I. (1946). An observational method to overcome zero drift error in field instruments.
Geophysics, 11(4), 466–490. https://doi.org/10.1190/1.1437276
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Continuous-model correction
 
The continuous-model drift correction treats model drift as a continuous function. The main
advantage over the network-adjustment drift correction is that it allows a non-linear spline
model, which is often the best fit for survey data recorded using a ZLS Inc. Burris relative-
gravity meter (in contrast, Scintrex meters typically have higher, more linear drift rates).
 
The continuous drift model is developed from repeated station occupations (that is, when
a station is visited more than once, with other stations occupied in between). Each station-
repeat provides one observation of relative-meter drift. Ideally, repeats will occur with
relatively little elapsed time between, over a period when the drift is nearly linear. As the
length of time between station repeats increases, drift is likely to become increasingly
non-linear, and the drift estimate less suitable for forming the continuous drift model. The
elapsed time can be visualized on the continuous-drift plot with the "Show time extent of drift
observation" option under Plotting options.
 
Successful application of the continuous-model drift correction depends on accurate
observations of gravity-meter drift, which in turn depends on repeat occupations with
minimal elapsed time in between. To accomplish that, it may be necessary to adapt the
survey design. In particular, observing stations in loops (i.e., visiting 5 or 6 stations before
returning to the initial station) may allow too much time to elapse for a representative drift
estimate to be obtained.
 

Drift plot
 
This plot shows the change in gravity at each station, relative to the initial occupation

at that station. Each line depicts a unique station. Steeper lines (positive or negative)
indicate a larger drift rate. The points that make up each line can be filtered using the "Max.
time between repeats" option. A vertical offset between each line can be added with the
"Vertical line offset" slider control.
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Drift rate plot
 
This plot shows the drift rate, calculated each time a station is repeated. Each point in this plot

represents the slope (i.e., the drift rate) of the line directly above in the drift plot.

 

Relative-gravity differences table

 

Plot controls
 
See Plotting options for more information.
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Tare table
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5. Network adjustment tab
 

The network adjustment tab provides information about the least-squares network
adjustment. The basic workflow is to:

1.  Populate the delta table with relative-gravity differences
2.  Add datum observations manually or from a file
3.  Perform the network adjustment
4.  Evaluate the adjustment statistics
5.  Revise by removing outliers and/or adjusting the standard deviations
6.  Export results
 

The parts of the network adjustment tab are:
 

 

Delta table
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The delta table shows the relative-gravity differences and associated information.
See delta-g observations for more information.

Datum table

The datum table shows the "reference" values for the network adjustment. They can
be observed values from an absolute gravity meter, or arbitrary value. At least one
datum is required for network adjustment.

Adjustment results
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The adjusted station values are shown in the adjustment results table at top right.
This table can be selected by clicking in the top left and copied by right-clicking.

Adjustment statistics

The adjustment statistics are shown in the table at bottom right. If Gravnet inversion
is used, the results are taken directly from the Gravnet output.
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Delta-g observations
 

Delta-g observations are shown in the Delta table on the network adjustment tab:
 

 
Delta-g observations (also called relative-gravity differences) must be populated (that is,
copied from their respective loops to the Network Adjustment tab) using menu commands
on the Adjustment menu. Delta-g's for all surveys can be populated at once, or individual
surveys, or individual loops. The latter options are useful to verify that individual loops can
be adjusted correctly before adjusting the entire survey or campaign.
 
Delta-g's can be unchecked to exclude them from the network adjustment. For the "none",
"adjustment", or "continuous" drift methods, the start/end times, and duration between them
are shown. For the Roman method, the time at which the delta-g is calculated is shown.
 
Two columns for standard deviation are shown: that calculated from the station observations
and/or drift method ("Std. dev." column), and the standard deviation used in the network
adjustment ("SD for adj." column). The latter can be adjusted if needed by specifying a
minimum value, or multiplier (see Network adjustment options). This is helpful to avoid
giving too much weight to delta-g's with very small standard deviations.
 
The standard deviation for the network adjustment ("SD for adj." column) can also be
manually edited. Care should be taken with this option because the fact that the standard
deviation was modified may not be obvious. The modified standard deviation will be saved
with the workspace, and a record of the modification is stored in the log file. If the standard
deviations are scaled after the initial adjustment, the user-modified standard deviations are
also scaled.
 
If the drift-correction type is none, network adjustment, or continuous, the delta-g value
can also be modified. This can be useful when troubleshooting bad observations, or hand-
entering datasets. If modified, the delta-g value is shown in red.
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The other items in the table cannot be modified. However, stations can be renamed in the
tree view.
 
Before network adjustment, the Residual column shows the default value -999. After
network adjustment this column shows the difference between the adjusted delta-g and the
measured delta-g. Clicking the column header sorts by residual magnitude.
 
Delta-g observations are linked to their respective values on the drift tab. If the drift method
for a loop is changed, all of the delta-g's for that loop on the Network Adjustment tab are
cleared and replaced with the new delta-g's (any modified delta-g's or standard deviations
will be lost). Also, if the station values are changed (by selecting/deselecting samples), the
respective delta-g's will automatically update.
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Datum observations
 

Datum observations are shown in the Datum table on the network adjustment tab:

 
Datum observations are the "known" values from which delta-g's are observed. At least
one datum observation must be present for each survey to perform an adjustment. A
datum observation can be an arbitrary value, such as 0 or 50,000, or it can be a measured
absolute-gravity value. There are three options for adding datum observations:
 

1.  Adding manually
2.  Importing from text file
3.  Importing from g files

 
When datum observations are added, they are associated with the currently selected survey.
Datum observations can be excluded from the network adjustment by unchecking their
respective checkbox.
 
Datum observations, as shown in the Datum table, include the following fields:

•  Station name
•  Gravity (µGal)
•  Standard deviation (µGal)
•  Date
•  Measurement height (centimeters)
•  Gradient (µGal/m)
•  Residual (µGal)

 
The first three (name, gravity, standard deviation) are required. The station name must
match exactly at least one station with a delta-g observation (names are case sensitive).
The date is not used (datums are associated with the selected survey when they are
added). The measurement height and gradient are used to transfer an absolute-gravity
measurement from the measaured height (about 71 cm or 131 cm for the A-10 and FG-5
absolute-gravity meters, respectively) to the land surface (i.e., the height of the relative-
gravity meter). The gravity value for the respective datum measurement is increased by the
amount [measurement height] * abs([gradient]) (the gradient shown in the Datum table is
negative to indicate gravity decreases with elevation). Finally, the residual column in the
Datum table shows the difference between the specified absolute-gravity value and the
network adjusted value. If only one Datum observation is specified, the residual will be zero. 
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The date, g, standard deviation, measurement height, and gradient fields can be changed by
double-clicking on the respective cell.
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Adding manually
 
Datum observations are added manually using the menu option Adjustment > Add datum
observation..., which brings up the following dialog:
 

 
The dropdown list shows all of the current stations in the Delta-g table. After clicking OK, the
selected station is added to the Datum table with a default value of 50,000 +/- 5 µGal.
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Importing from text file
 
Datum observations are added from a text file using one of two menu options: Adjustment >
Import abs. g (simple)..., or Adjustment > Import abs. g (complete)... Either choice opens a
standard file open dialog. The file formats are:
 
Simple format - a space-delimited file with no header and the columns
STATION GRAVITY STDEV
 
Complete format - a comma-delimited file with one header line. GSadjust will import data
from the following columns (case-sensitive)
Gravity, Station Name, Set Scatter, Date, Transfer Height, Gradient
 
The columns may be in any order, and other columns may also be present.
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Importing from g files
 

Datum observations can be added directly from *.project.txt files generated by 'g' software
(Micro-g Lacoste, Inc.) using the menu option Adjustment > Import abs. g from database,
which brings up the following dialog:

 
First, navigate to the directory with *.project.txt files. The Load button scans the chosen
directory and subdirectories. Metadata for each observation is shown in the table. Check the
observations to import and select the Import button.
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Network adjustment
 
Least-squares network adjustment is the process for solving the system of equations that
represent all of the survey observations (relative-gravity differences, and absolute-gravity
observations), along with any additional parameters that describe relative-gravity meter drift
and calibration.
 
In brief, network adjustment solves the system of equations, represented in matrix form as:
 
L + V = AX
 
where L is an n x 1 vector of relative-gravity (delta-g's) and absolute-gravity measurements ,
V is a n x 1 vector of residuals, A is the n x m design matrix, and X is a m x 1 vector of
unknowns, that is, the gravity value at each station and relative-gravity meter parameters
that describe drift and meter calibration. The value n is the total number of observations
(both delta-g's ad absolute-gravity), and m is the number of unknowns (number of gravity
stations plus the number of gravity-meter parameters).
 
GSadjust can solve the system of equations using the least squares routine in the Python
Numpy package (using the linalg.inv method), or using the program Gravnet. The solution
to use is selected with the Adjustment > Adjustment type... menu. Prior to adjustment,
adjustment options, including whether to include a calibration coefficient, are set using the
Network adjustment options dialog.
 
After successful adjustment, station values are shown in the Adjustment results table in the
upper right part of the Network adjustment tab. Statistics about the adjustment results and
meter parameters (drift and calibration, if included in the adjustment) is shown in the lower
right part.
 
Note that the delta-g's shown in the Delta table on the Network adjustment tab are
effectively static once the Delta table is populated. If changes are made to the samples
that comprise each station occupation, or the drift method, the Delta table must be cleared
(Adjustment menu > Clear delta table) and repopulated.
 
Oftentimes it is helpful to adjust the network in pieces (individual loops or surveys) prior
to adjusting the campaign (or a survey) as a whole. This can be accomplished using the
"Populate delta table - selected survey" and (or) "Populate delta table - selected loop"
options on the Adjust menu.
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Network adjustment options dialog
 

This dialog provides options for performing the network adjustment. Options 1-4 are used
to calculate the value shown in the "SD for adj." column of the Delta Table, which is the
standard deviation used in the network adjustment.

 
 

Standard deviation multiplier, pre-minimum
When checked, multiplies the delta-g standard deviation (determined from the data
and/or drift-correction method) by the specified value prior to enforcing the
minimum standard deviation (if checked). May be used in conjunction with "Add to
std. dev." (multiplier is applied first).
 
If the minimum standard deviation box is not checked, this value is modified when
scaling the standard deviation after an adjustment.

Standard deviation multiplier: post-minimum
When checked, multiplies the delta-g standard deviation (determined from the data
and/or drift-correction method) by the specified value after enforcing the minimum
standard deviation (if checked). May be used in conjunction with "Add to std.
dev." (multiplier is applied first).
 
If the minimum standard deviation box is checked, this value is modified when
scaling the standard deviation after an adjustment.

Add to standard deviation: pre-minimum
When checked, adds the specified value to the delta-g standard deviation
(determined from the data and/or drift-correction method) prior to enforcing the
minimum standard deviation. May be used in conjunction with "Add to std.
dev." (multiplier is applied first).
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Minimum standard deviation
When checked, the delta-g standard deviation used in the adjustment is the greater
of the specified value, or the standard deviation determined from the data and/or
drift-correction method.
 

Calculate relative meter calibration coefficient
When checked, a relative-meter calibration coefficient (scale factor) is calculated
during the network adjustment. The calibration coefficient is a multiplier applied to all

relative-gravity observations. It is calculated from the datum observations in a network, and
2 or more datum observations are required. If more than one relative-gravity meter is used
on a survey, the calibration coefficient must be calculated or specified for all meters (if not
specified, it is set to 1.0).

Specify calibration coefficient
When checked, the specified relative-meter calibration coefficient is applied during
the network adjustment. The calibration coefficient is a multiplier applied to all
relative-gravity observations. A coefficient for each meter must be provided in the
calibration coefficient table.

Calibration coefficient table
If the Specify calibration coefficient checkbox is checked, each delta-g is multiplied
by the gravity-meter specific coefficient in the calibration coefficient table.

Significance level for global model test
Significance level for the chi-square test used to evaluate adjustment residuals.

Restore defaults button
Restores default values in dialog box. One of the "Apply..." buttons must be selected
to apply values.

Apply to current survey button
Applies the network-adjustment options to the survey curently selected in the data
tree view at the left side of the window (The current survey is highlighted in bold).
 

Apply to all surveys button
Applies the network-adjustment options to all surveys in the campaign.
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Evaluating the adjustment
 
The network adjustment summary and statistics are shown in the bottom right of the
Network adjustment tab. If using Gravnet for adjustment, the adjustment results are taken
from the *.gra file written by Gravnet. If using Numpy for adjustment, similar output is shown.
 
In either case, the primary metrics for evaluating the adjustment is the Chi-square goodness
of fit test, the reference factor, and the observation residuals.
 
Chi-square test
 
The Chi-square test is a standard metric when adjusting survey observations of all types.
The test involves calculating the Chi-square statistic:
 

 
from the residuals (vi, the difference between observed and adjusted delta-g's and datum
values) and their respective weights (pi). The statistic is compared to a critical value,
calculated for the network degrees of freedom (number of observations) and the significance
level. The default significance level is 0.05 (5 percent) but can be changed in the Network
adjustment options dialog.
 
The result of the Chi-square test ('accept' or 'reject') is shown in the bottom right of the
Network adjustment tab.
 
Scaling the standard deviation
 
For network adjustment statistics to be accurate, the estimated standard deviations of the
input data must be accurate. This can be evaluated with the standard deviation a posteriori
statistic ("SD a posteriori") in the least-squares statistics in the bottom right of the Network
Adjustment tab. A value less than 1 indicates input standard deviation is too high; greater
than one indicates input standard deviation is too low. Using the Adjustment menu > Scale

standard deviation from results command (or the  button on the Tree View toolbar), the
standard deviation of the delta-g's is scaled automatically so that the standard deviation a
posteriori statistic approaches one. See adjustment options for more information on how the
scaling is applied.

 
Only the gravity-difference standard deviations are scaled; the datum observation standard
deviations are not.
 
Plots
 
Two plots are useful for evaluating the adjustment. The first, shown when the "Adjustment
> Plot residual histogram" menu item is selected, is a histogram of the delta-g residuals
(i.e., the difference between each observed delta-g and the adjusted delta-g). This plot
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should approximately follow a normal distribution, with no large outliers. The second plot,
"Adjustment > Plot adjusted datum vs. measured", shows a bar plot of the difference
between the datum observations (e.g., absolute-gravity measurements) and the adjusted
values. The closer these residuals are to zero, the better the adjustment.
 
For campaigns with several surveys, a time series version of the "adjusted datum vs.
measured" plot is available. Rather than columns, this plot shows the adjusted value and
measured values as separate time-series for each station.
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Outliers and standard deviation
 
Outliers and the standard deviation of the observations can both have a significant impact
on the adjustment results. The relative-gravity meter—both metal and quartz-spring versions
—is suspect to periodically recording a "bad" measurement. At times these may be tares
(offsets that persist across subsequent measurements) or extreme drift, but at other times,
only a single reading seems to be bad (based on repeat observations at that station). The
ability to quickly and iteratively remove potential bad measurements is an important function
of GSadjust.
 
Similarly, the standard deviation of the observations may need updating when adjusting a
network. The weight of each observation is proportional to 1 over the variance (standard-
deviation squared). For example, an observation (delta-g or datum) with standard deviation
of 5 µGal would have 1/25 the weight of an observation with a standard deviation of 1 µGal.
This range of standard deviations (or greater) is not uncommon for field surveys.
 
Outliers
 
Observations can be removed from the adjustment by unchecking the appropriate checkbox.
If the checkbox next to a station in the Data tree view is unchecked, the respective delta-
g table on the Drift tab will be updated. In this case, the delta-g table on the Network
adjustment tab will need to be updated using one of the "Populate delta table..." commands
(the delta-g tables also need to be updated after changing the drift method).
 
In addition to unchecking individual station occupations, delta-g's can be unchecked on the
Network adjustment tab. The delta-g table does not need to be updated, but the "Adjust
network" command must be run to update the adjustment results. After the initial adjustment,
by sorting the delta-g table by the adjustment residual (by clicking the column header), the
worst observations can be identified and potentially removed. By cross-referencing the
residuals with stations and occupation times, it may be possible to identify problem stations,
or periods of bad data.
 
Datum observations can also be removed from the adjustment by unchecking the respective
checkbox. The "Adjust network" command must be run to update the adjustment results.
 
Standard deviation
 
The standard deviation of the observations may need updating based on the adjustment
results. As noted, it may be undesirable to have a wide range of standard deviations,
thus giving some undue weight. A second reason to update the standard deviation of the
observations is to meet the the Chi-square test criteria. if the a priori standard deviations
are too low (that is, the observations are worse than estimated), the Chi-square test will be
rejected.
 
Standard deviations of delta-g's and datums can be edited directly by double-clicking the
respective cells on the Network adjustment tab. More efficiently, a minimum standard
deviation, additive term, or multiplier can be applied to all of the delta-g's in a survey or
campaign in the Network adjustment options dialog.
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Exporting results
 
After performing the network adjustment, results can be obtained by copy-paste or exporting
to a tabular text file. In addition, if the "Write output files" option is checked in the Network
adjustment options window, station gravity values (and other information) are written to disk.
 
To copy adjusted gravity values to the clipboard, click the upper-left corner of the Results
table. This will highlight the table. Next, right-click on the table and select "Copy to
clipboard". The table can now be pasted into a text editor or spreadsheet program (the
keyboard shortcut Ctrl-C cannot be used to copy in this context). 
 

Click here to select table
To export results to a tabular (.csv) text file, select the command "Write tabular data" on the
Tools menu. This will write a file named GSadjust_TabularDataYYYYMMDD-HHMM.csv,
with the date and time the file was written. The file will have the columns station name,
latitude, longitude, and elevation, and for each survey, g and the standard deviation of g
from the network
adjustment.
 
In addition, a table of gravity change between surveys can be exported from the Compute
gravity change window.
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6. Other tools
 
GSadjust includes other tools for evaluating and publishing gravity results:
 
Network visualization - plots gravity differences between stations.
Metadata export - text summary of adjustment results for creating metadata.
Vertical gradient calculation - for calculating the vertical gradient when a specific gradient
survey is done.
Tide correction - an alternative to the meter-supplied tide model.
Show/edit station coordinates - dialog for editing station coordinates, for map-view plots.
Calculate gravity change over time - tools for showing and plotting gravity differences
between surveys.
Logging - logging window for record keeping and troubleshooting.
Loop animation - shows the sequence of station observations in a survey.
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Network visualization
 
Network graphs of the relative-gravity observations are available using the menu options
Network graph - circular and Network graph - map view, on the Tools menu. The first option
plots stations equally spaced around a circle, whereas the latter plots stations according
to their spatial location (in Cartesian coordinates; map projections are not supported). For
either option, line weight is proportional to the number of delta-g's between any two stations.
Enabled delta-g's (unchecked in the Delta Table) are plotted as gray lines. Disabled delta-g's
are plotted as red lines.
 
Network graph - circular

 
Network graph - map view (Latitude/Longitude coordinates)
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Metadata export
 
When publishing network-adjusted gravity data, it should be accompanied by a description
of the processing. Complete geospatial metadata, typically provided in XML format, meets
the FGDC or ISO 19115 standard. Many tools exist to prepare such metadata, and typically
a specialized editor is required to meet the specific format and fields required by the
standards.
 
To assist in the preparation of metadata, the Tools > Write metadata text menu command
will write narrative text to a file in the data directory with details of the network adjustment,
including:
 

•  Minimum and maximum delta-g residuals
•  Minimum and maximum datum observation residuals
•  Average standard deviation of the adjusted gravity values
•  Number of delta-g's included in the adjustment
•  Number of excluded delta-g's
•  Number of datum observations included in the adjustment
•  Number of excluded datum observations
 

Typically this metadata text would be included in the Attribute Accuracy Report section of
FGDC metadata.
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Vertical gradient calculation
 
Vertical gradients (the change in gravity with vertical position, in units of microGal/m) are
typically measured by moving a relative-gravity meter between the land surface and (or)
two or more positions on a tripod. Typical tripod heights are 71 cm (the height of the A-10
absolute-gravity meter) and 131 cm (the height of the FG-5 absolute-gravity meter).
 
If data are collected at two heights (typically, one at the land surface and one elevated,
but any two heights are possible) GSadjust can calculate the vertical gradient by dividing
the gravity difference by the height interval. This process requires the Roman drift method
be used. The height interval is specified by the menu option Process > Vertical gradient
interval... The default value is 64.2 cm; if the tripod is set to this height the sensor of
a LaCoste and Romberg D or G relative-gravity meter is located at approximately the
measurement height of the A-10 absolute-gravity meter. 
 
Vertical gradients are calculated with the menu option Process > Write vertical gradient file...
This opens a file save dialog. The resultant file, a text file with the extension .grd, has a
single value and uncertainty (in units of µGal/cm).
 
At this time GSadjust will only calculate a two-point, first-order linear gradient.

http://go.usa.gov/xqBnQ
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Tide correction
 
Although most modern relative-gravity meters provide real-time tide correction based on
station location, GSadjust provides the option to replace the meter-provided tide correction
with calculated tides using the Agnew model, from the software Predict, or from a Tsoft-
format text file. The tide correction is changed using the Process > Tide correction menu
item. This shows a dialog box in which the method can be selected:
 

 
Note: The Agnew code was originally developed for PyGrav (Hector and Hinderer, 2016).
The accuracy of this code has not been independently verified.
 
Meter-supplied
 
If the tide model has been changed after loading a data file (using one of the options below),
selecting Meter-supplied in the dialog will restore the original meter tide correction. If the tide
model has not been changed, this option will have no effect.
 
Agnew
 
The Agnew correction calculates a theoretical solid-Earth tide based on station and time
(Agnew 2007, Agnew 2012). The station occupation times must be recorded in UTC. The
tide is calculated for a single location. When the Agnew option is selected, the user is
prompted to enter coordinates:
 

 
The default coordinates are calculated as the average of the station locations.
 
 
 
Agnew, D.C., 2007, 3.06 - Earth Tides, in Schubert, G. ed., Treatise on Geophysics,
Amsterdam, Elsevier, p. 163–195.
 
Agnew, D.C., 2012, SPOTL: Some Programs for Ocean-Tide Loading
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Hector, B., & Hinderer, J. (2016). pyGrav, a Python-based program for handling
and processing relative gravity data. Computers & Geosciences, 91, 90–97. https://
doi.org/10.1016/j.cageo.2016.03.010
 
Van Camp, M., & Vauterin, P. (2005). Tsoft: graphical and interactive software for the
analysis of time series and Earth tides. Computers & Geosciences, 31(5), 631–640. https://
doi.org/10.1016/j.cageo.2004.11.015
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Show/edit station coordinates
 
Station coordinates are used to plot the network graph in map view, and to plot gravity-
change results. They are not used directly for the tide-correction model; those coordinates
are specified in a dialog box when a tide correction is run.
 
Station coordinates are populated when a data file is read. Station coordinates may be
viewed or updated using the Show station coordinates... command on the Edit menu. The
table shown in the popup can be copied and pasted. For example, the table could be copied
to Excel, updated with post-processed GPS coordinates, and pasted back into GSadjust.
 

http://go.usa.gov/xqBnQ
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Calculating gravity change over time
 
If two or more Surveys are present in a Campaign, GSadjust can calculate the change in
gravity over time using the Process > Compute gravity change menu option. This opens a
new window that displays a table of gravity change:

Three table formats are selectable from the drop-down list:
 
Simple: Includes gravity change is calculated between each successive survey, and
cumulative change is calculated from the first survey. One row per station.
 
Full: Includes station coordinates, adjusted gravity values and standard deviation, and
gravity change converted to meters of water. One row per station.
 

http://go.usa.gov/xqBnQ
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List: Includes station name, date, adjusted gravity value, and standard deviation. One row
per station per survey.
 
To export results, select cells in the table (Ctrl-a to select all), and select the "Copy to
clipboard" button at the bottom of the table.
 
The complete table can also be exported by selecting the Tools > Write tabular data menu
option.
 
Gravity-change time series can be plotted with the Plot and Map buttons.
 

http://go.usa.gov/xqBnQ
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Plotting gravity time-series
 

The gravity-change time series can be plotted with the Plot button on the gravity change
table. Gravity change is plotted relative to the first occupation at each station. The plot can
be saved as an .svg file from the Matplotlib toolbar for further editing in Illustrator or other
graphics packages.
 
Individual lines can be removed from the plot by clicking the line in the legend. All lines can
be deleted by clicking the right button, or restored by clicking the middle button.
 
More extensive plotting requires saving the gravity-change table by copy and pasting it or
saving as a text file with the Tools > Write tabular data menu option.
 

http://go.usa.gov/xqBnQ
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Map-view gravity change
 

This window shows a presentation-style view of gravity change with an optional basemap.
Station coordinates must be present in the input file.
 
Note: Using the basemap option requires an internet connection. GSadjust can become
unresponsive while downloading a basemap; at the default resolution 10-30 seconds is
usually required. .

 

Toolbar

 
The standard Matplotlib toolbar. Use the magnifying glass to zoom in; right-click
zooms out.

Change interval

http://go.usa.gov/xqBnQ
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Gravity change can be plotted between successive surveys (the Incremental
option), or relative to a particular survey (such as the first survey). Also, a linear
gravity trend in µGal/yr can be calculated at each station.

Basemap

An optional basemap can be shown. Several options are available in the dropdown.
Basemap resolution can be changed using the slider (uncheck/check to refresh).
High-resolution basemaps can result in slow loading times.

Show change in meters of water

Gravity change can be converted to meters of water using the Bouguer slab
approximation (41.9 microGal = 1 meter of free-standing water)

Color range

This slider controls the color range. If extreme values are present, they may mask
small changes. The color range can be reduced by moving the slider leftward.

Time slider

Controls the date range shown in the plot.

http://go.usa.gov/xqBnQ
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Logging
Actions undertaken and error messages are logged to file to assist in troubleshooting errors
and showing the steps taken to arrive at a given workspace. The log file is saved in the
GSadjust main directory with the filename GSadjustLog_YYYYMMDD-hhmm.txt.
 
The log file can be shown by selecting "Log window" from the help menu.
 

http://go.usa.gov/xqBnQ
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Loop animation
When reviewing data, especially when the reviewer did not collect the data, it can be
helpful to visualize the survey progression in map view. To do so, right-click on a loop in
the tree view and select Animate loop. This will open a new window with an animated line
proceeding from the first to last station occupation, after which the animation repeats.
 

Anim

http://go.usa.gov/xqBnQ
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Show calibration coefficients
 
For campaigns with several surveys, it can be useful to see how the calibration coefficients
compare. The Tools > Show calibration coefficients shows the following table:
 

 
Standard deviation equal to 0 indicates a specified calibration coefficient.

http://go.usa.gov/xqBnQ
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7. Considerations
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Dynamic data links between tabs and status indicators
 

 
GSadjust links data across the data, drift, and network adjustment tabs. If station gravity
values change (by unchecking samples in the Data Table on the Data tab), the respective
gravity differences relative to that station on the Drift and Network Adjustment tabs are
immediately updated. This facilitates an iterative workflow.
 
Although the gravity differences are updated, the network adjustment is not automatically
repeated if station gravity values change. The user must repeat the "Adjust network"
command on the Adjustment menu. If station gravity values have changed since the
previous adjustment, a circular red indicator in the bottom right if the GSadjust window is
shown. The indicator is cleared after performing the adjustment.
 
When changes are made to the current loop drift correction method (for example, changing
the type from None to Continuous, or enabling the maximum time between repeats
threshold, the respective delta-g's for that loop on the Network Adjustment tab are updated
immediately and the adjustment results are invalidated. If the delta-g's for that loop aren't
included on the Network Adjustment tab (for example, if the delta table has not yet been
populated, or was populated with only a subset of loops, not including the current loop),
changing the drift correction method won't affect the deltas on the Network Adjustment tab.
 
In addition to the station gravity values, the check status of each station in the left-hand tree
view affects the data to be analyzed. When a station is unchecked, the delta-g's that include
the station are immediately removed from the Drift and Network Adjustment tabs.
 
By disabling relative-gravity differences through unchecking one of the constituent stations,
the influence of potentially bad station occupations can be rapidly assessed.

http://go.usa.gov/xqBnQ


 

GSadjust Manual
USGS Southwest Gravity Program

104

                             

Numpy vs Gravnet inversion
 
Two options exist for the least-squares solution of the network adjustment, Numpy or
Gravnet (Hwang et al., 2002). Gravnet is a Fortran program, and a compiled executable
for Windows is provided with GSadjust. Gravnet uses Cholesky decomposition to invert the
design matrix and solve the network adjustment system of equations. The numpy inverse
solution (using numpy.linalg.inv) uses the LAPACK linear algebra package's Gaussian
elimination routine.
 
For most network adjustment solutions the Numpy and Gravnet solutions will be identical,
and run equally fast. There are three main differences in functionality:

•  Gravnet only accomodates a single relative-gravity meter when calculating a
calibration coefficient; the Numpy solution will calculate a unique calibration coefficient
for each relative-gravity meter.

•  When drift is included as a polynomial to be solved for in the least squares solution,
Gravnet is limited to a single polynomial for all observations in a Survey. That is, if
the drift method on the Drift tab is set to "Network adjustment", all Loops in the same
Survey must also be set to "Network adjustment", all with identical polynomial degrees.
With the Numpy solution, the drift method can be set independently for each loop. If
necessary, the "Network adjustment" method may be used for some loops, and an
alternative method used for other loops within the same survey.

•  Gravnet includes Pope’s t-test method to test for outliers; Numpy inversion does not
perform outlier tests.
 

Gravnet can also solve for circular (screw) error, but this option is not currently implemented
in GSadjust.
 
Gravnet is provided as a Windows executable; it will not run on non-Windows computers
unless the Fortran source code is compiled for the specific platform.
 
 
 
Hwang, C., C. Wang, and L. Lee (2002), Adjustment of relative gravity measurements using
weighted and datum-free constraints, Comput. Geosci., 28, 1005–1015.

http://go.usa.gov/xqBnQ
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Vertical gradients
 
The vertical gravity gradient, expressed in µGal/cm, has two functions in combined absolute/
relative gravity surveys. First, the gradient is used in the absolute gravity data-collection
software ('g', by Micro-g LaCoste) to calculate g, because gravity varies over the height
of the free-fall. Especially for the A-10 meter, having a relatively short free-fall, the vertical
gradient has only a minor effect on g and a standard value (-3 or -3.086 µGal/cm) is often
used. Second, and more importantly, the vertical gradient is used to calculate g at the
transfer height at which it is reported. Typically the transfer height is 100 cm, whereas the
A-10 measures at about 71 cm, and the FG-5 at about 131 cm.
 
The latter application of the vertical gradient is important when combining relative and
absolute measurements, which are typically made at different measurement heights.
Generally the absolute-gravity measurement is transferred from the transfer height to the
land surface (or, the measurement height of the relative-gravity meter). GSadjust uses
the transfer height and gradients shown for each datum in the Datum Table to transfer the
absolute-gravity value to the land surfacer (these are imported from the *.project.txt files
output by 'g' if the "Import abs. g - complete" menu option is selected). An offset equal to
[transfer height] * [gradient] is added to each datum. If the imported/specified absolute-
gravity value (or datum) should be used as-is, the transfer height should be set to zero. If the
gradient is the same for every datum, it will have no effect; a constant offset will be added to
each datum.
 
The adjusted gravity value at each station in the Results Table has the transfer offset applied
(that is, it is the gravity value at the land surface). When comparing adjusted to measured
values at datum stations, the offset is taken into account.
 
Vertical gradients are typically measured over a discrete interval using a relative-gravity
meter and a tripod or similar stand. A mini loop is measured between the ground and the
measurement height of the A-10 or FG-5 meter; typically the ground is occupied 3 or 4
times, and the tripod 2 or 3 times (additional occupations may improve accuracy). If this
type of survey, with only two stations, is processed with GSadjust, the menu option "Write
vertical gradient file..." can be used to calculate a vertical gradient, in microGal/cm, and write
it to file. The gradient is calculated over the interval specified in the dialog opened by the
"Vertical gradient interval..." menu command.

http://go.usa.gov/xqBnQ
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Saving and loading the workspace
 
At any point the current workspace can be saved using the "Save workspace..." menu
command. This writes the stations, loops, and surveys of the campaign, along with their
checkbox states, drift method(s), delta-g's, and datums, to a file with a *.gsa extension.
The file is written in JSON format and can be read using a text editor. Hand-editing the file,
however, will likely lead to errors. Adjustment results are not saved. Saved workspaces can
be imported using the "Load workspace..." menu command.
 
 

http://go.usa.gov/xqBnQ
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Multiple meters
 
GSadjust can accommodate data from more than one relative-gravity meter, and, if
absolute-gravity observations are present, determine the calibration coefficient for each
meter during the least-squares network adjustment. The presence of multiple meters is
determined automatically based on the serial numbers read from the raw data files. The
calibration coefficient option must be selected in the Network adjustment options dialog on
the Adjust menu. If this option is selected, a calibration coefficient will be determined for all
meters (there is no option to calculate a coefficient for some meters and not others used on
the same Campaign). If the calibration coefficient is to be determined for multiple relative-
gravity meters, the Numpy adjustment option must be selected; Gravnet cannot accomodate
more than one meter.

http://go.usa.gov/xqBnQ
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