Commit e789e356 authored by Laura A DeCicco's avatar Laura A DeCicco
Browse files

Let's try this

parent 68222758
# Workflow derived from https://github.com/r-lib/actions/tree/master/examples
# Need help debugging build failures? Start at https://github.com/r-lib/actions#where-to-find-help
on: on:
push: push:
branches: main branches: main
...@@ -6,44 +8,25 @@ name: pkgdown ...@@ -6,44 +8,25 @@ name: pkgdown
jobs: jobs:
pkgdown: pkgdown:
runs-on: ubuntu-18.04 runs-on: ubuntu-latest
env: env:
RSPM: https://packagemanager.rstudio.com/cran/__linux__/bionic/latest GITHUB_PAT: ${{ secrets.GITHUB_TOKEN }}
steps: steps:
- uses: actions/checkout@v2 - uses: actions/checkout@v2
- uses: r-lib/actions/setup-pandoc@v1
- uses: r-lib/actions/setup-r@v1 - uses: r-lib/actions/setup-r@v1
id: install-r with:
use-public-rspm: true
- uses: r-lib/actions/setup-pandoc@v1 - uses: r-lib/actions/setup-r-dependencies@v1
with:
- name: Install pak and query dependencies extra-packages: pkgdown
run: | needs: website
install.packages("pak", repos = "https://r-lib.github.io/p/pak/dev/")
install.packages(c("DT", "leaflet", "zoo", "maps", "patchwork"))
saveRDS(pak::pkg_deps("local::.", dependencies = TRUE), ".github/r-depends.rds")
shell: Rscript {0}
- name: Install system dependencies
if: runner.os == 'Linux'
run: |
pak::local_system_requirements(execute = TRUE)
pak::pkg_system_requirements("pkgdown", execute = TRUE)
shell: Rscript {0}
- name: Install dependencies
run: |
pak::local_install_dev_deps(upgrade = TRUE, dependencies = c("all", "Config/Needs/website"))
pak::pkg_install("pkgdown")
shell: Rscript {0}
- name: Install package
run: R CMD INSTALL .
- name: Deploy package - name: Deploy package
run: | run: |
git config --local user.name "$GITHUB_ACTOR" git config --local user.name "$GITHUB_ACTOR"
git config --local user.email "$GITHUB_ACTOR@users.noreply.github.com" git config --local user.email "$GITHUB_ACTOR@users.noreply.github.com"
Rscript -e 'options(rmarkdown.html_vignette.check_title = FALSE); pkgdown::deploy_to_branch(new_process = FALSE)' Rscript -e 'pkgdown::deploy_to_branch(new_process = FALSE)'
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment