Verified Commit f61c98bc authored by Hill, Clifford (Contractor) John's avatar Hill, Clifford (Contractor) John
Browse files

More doc updates.



Signed-off-by: Hill, Clifford (Contractor) John's avatarCliff Hill <chill@contractor.usgs.gov>
parent 89e642b3
......@@ -10,11 +10,15 @@ Prerequisites
[Cookiecutter](https://github.com/audreyr/cookiecutter) to be
installed in order to be used.
- The project that is created requires the use of
[conda](https://www.anaconda.com), and will expect that tool to be
[Conda](https://www.anaconda.com), and will expect that tool to be
available.
- The project that is created also needs to have conda-build set up and running in order
to build the project and deploy it to conda.
- The project that is created also uses [poetry](https://python-poetry.org) for dependency management
- The project that is created also uses [poetry](https://python-poetry.org) for dependency management.
To install poetry, use the following:
``` {.sourceCode .console}
$ curl -sSL https://raw.githubusercontent.com/python-poetry/poetry/master/get-poetry.py | python -
```
- Other than the use of [conda](https://www.anaconda.com), this follows the patterns
defined in [Hypermodern
Python](https://medium.com/@cjolowicz/hypermodern-python-d44485d9d769).
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment